Previous and Next Buttons Broken?

Is something wonky on the site? Describe the problem to us, and we'll fix it ASAP.
Forum rules
Bug Reporting Guidelines

Before Posting
Please make sure someone hasn't already reported the problem you're experiencing before creating a new topic. Confirmed issues have been stickied in this forum.

Rules

    1) Use a descriptive title when starting a bug topic. Example: "Comic images not showing up" Do not use vague titles like, "problem" or "uh ohh"

    2) Describe your problem in detail. Explain exactly what is wrong. Post images, screen shots, links, code snippets - whatever is relevant. The better the information you provide, the better the solution you will receive.

    3) Be polite and patient. We fix these issues as fast as we can. Please be patient with us as we work toward a solution.

Previous and Next Buttons Broken?

Postby ryank_119 » September 30th, 2017, 8:20 am

My site is http://www.cityfolk.ca and my navigation bar is broken on IE and Firefox. Chrome works fine.
What's happening is users are being directed to the homepage when clicking "Previous" or "Next" under the comic. My navigation bar is an image map but so is my menu (which is working fine still).

This is my code:


Code: Select all
<img src="http://imgur.com/FGoa0UA.png" alt="" usemap="#Menu" / height=70px>
<map name="Menu" id="Menu">

    <area alt="" title="" href="{NAV_PREV}" shape="rect" coords="0,0,100,35" />

    <area alt="" title="" href="{NAV_NEXT}" shape="rect" coords="100,0,200,35" />

    <area alt="" title="" href="/postcomment.php?cid={COMIC_ID}" shape="rect" coords="0,35,100,65" onclick="var new_window = window.open('/postcomment.php?cid={COMIC_ID}', 'sj_comment', 'height=350, width=420'); new_window.focus(); return false;">

    <area alt="" title="" href="http://cityfolk.ca/archive" shape="rect" coords="100,35,205,65" />

</map>


If anyone has any ideas I would be so appreciative!
Image
User avatar
ryank_119
 
Posts: 86
Joined: November 12th, 2008, 8:49 pm
Location: Okanagan, BC

Re: Previous and Next Buttons Broken?

Postby eishiya » September 30th, 2017, 10:27 am

The problem is you have two image maps named "menu", your upper menu and your navigation menu. The names are not case sensitive, so "menu" and "Menu" are the same name, and which is used is implementation-dependent. Chrome and my version of Firefox use the closest and intended map, but IE and Edge use the first map, which is meant for the main menu. Rename "Menu" to something like "navMenu" and it should work. Remember to also change the id to the new name.

Also, unrelated:
<img src="http://imgur.com/FGoa0UA.png" alt="" usemap="#Menu" / height=70px>
that ain't right xP Fix:
Code: Select all
<img src="http://imgur.com/FGoa0UA.png" alt="" usemap="#Menu" height="70" />
Image
User avatar
eishiya
 
Posts: 9832
Joined: December 5th, 2009, 11:17 am

Re: Previous and Next Buttons Broken?

Postby ryank_119 » September 30th, 2017, 3:59 pm

Oh crazy, I didn't even notice that! Thank you so much!
Image
User avatar
ryank_119
 
Posts: 86
Joined: November 12th, 2008, 8:49 pm
Location: Okanagan, BC


Return to Bugs & Glitches

Who is online

Users browsing this forum: No registered users and 4 guests